unsupported Kubernetes version (Service: Eks, Status Code: 400, Request ID) but its actually eksctl version!!!!

Firstly, sorry for the misleading error code as this forced even me to scratch my head and spend a few hours in order to figure…

Unable to create ArgoCD application, Error: manifest does not contain a layer with mediatype application/tar+gzip

We are utilizing ArgoCD for Gitops and everything works fine and the application is getting created with docker images stored in the ECR repository. But…

pgAdmin hosting on the Kubernetes and design advantages

pgAdmin 4 is a free open source graphical management tool for PostgreSQL. This article will help you to understand the advantages of hosting a pgAdmin…

Helm Push/Pull Error: scheme “OCI” not supported

There are a few issues reported by the developers when storing Helm charts in AWS ECR. Common errors occur when they are using the old…

Helm OCI based charts into AWS ECR and OCI feature

We are using AWS ecr for storing our application images and the AWS ecr support of Open Container Initiative (OCI) artifacts for Helm has greatly…

How to avoid Helm warning due to config permissions

When a developer working on Kubernetes he/she generally forgets to secure the Kubernetes config file that contains the cluster tokens of environments that can be…

GitOps using ArgoCD with Azure git repository

To learn more on ArgoCD you can visit documentation by clicking the link https://argo-cd.readthedocs.io/en/stable/ Let us start by generating the PAT for Azure Git Repository,…

Let’s Encrypt CN = R3: Certificate has expired or is not yet valid.

Manually Renew Let’s Encrypt Certificates via CLI I work with a series of Kubernetes clusters that are restricted to public access via Mutual authentication and…